viernes, 19 de mayo de 2006

Escalada de privilegios en SAP R/3

Se ha reportado una vulnerabilidad en SAP que puede ser aprovechada
por atacantes locales para escalar privilegios.

El fallo se debe a un error no especificado en el comando sapdba
al manejar ciertas variables de entorno. Este problema puede ser
aprovechado por atacantes locales para ejecutar comandos
arbitrarios con los privilegios del usuario informix.

La vulnerabilidad ha sido verificada en las siguientes versiones
para HP-UX, Solaris, AIX, TRUE64, y plataformas linux:
* el comando sapdba para Informix versión anterior a la 700.
* el comando sapdba para Informix versión 700 hasta con el parche 100.

El fabricante ha publicado una actualización para la vulnerabilidad.
Se recomienda ver la nota 944585 de SAP para más detalles.


Laboratorio Hispasec
laboratorio@hispasec.com


Más información:

Local Privilege Escalation in SAP sapdba Command
http://www.cybsec.com/vuln/CYBSEC_Security_Pre-Advisory_Local_Privilege_Escalation_in_SAP_sapdba_Command.pdf