domingo, 7 de septiembre de 2008

Ejecución remota de código a través de RADIUS en Cisco Secure ACS

Cisco ha publicado una actualización que corrige una vulnerabilidad en Cisco Secure ACS que podría permitir a un atacante remoto ejecutar código arbitrario.

La vulnerabilidad consiste en un error en RADIUS al analizar la longitud de un paquete de respuesta EAP (Extensible Authentication Protocol). Un atacante remoto actuando como cliente RADIUS podría provocar una denegación de servicio a través de un paquete EAP especialmente manipulado. También es posible conseguir la ejecución de código arbitrario.

Se confirma la vulnerabilidad para todos las versiones de Cisco Secure ACS para Windows y las siguientes versiones de Cisco Secure ACS Solution Engine (ACSE):
* Para la rama 3.x.y: Versiones inferiores a 3.3 compilación 12 con parche 6.
* Para la rama 4.0.x: Todas las versiones.
* Para la rama: 4.1.x: Versiones inferiores a 4.1 compilación 13 con parche 10.
* Para la rama 4.2.x: Versiones inferiores a 4.2 compilación 124 con parche 3.

Cisco, a través de los canales habituales, ha puesto a disposición de sus clientes soluciones para solventar el problema.

Se aconseja consultar la tabla de versiones vulnerables y
contramedidas en:
http://www.cisco.com/en/US/products/products_security_response09186a00809f140b.html


Laboratorio Hispasec
laboratorio@hispasec.com


Más información:

Cisco Security Response: Cisco Secure ACS Denial Of Service Vulnerability
http://www.cisco.com/warp/public/707/cisco-sr-20080903-csacs.shtml

No hay comentarios:

Publicar un comentario en la entrada