viernes, 20 de febrero de 2009

Adobe solucionará dentro de tres semanas una vulnerabilidad en Acrobat (Reader) que está siendo ya aprovechada por atacantes

La ShadowServer Fundation advirtió el día 19 de febrero de una potencial vulnerabilidad en Adobe Acrobat Reader que podría permitir a un atacante ejecutar código arbitrario. Al descubrirse el problema mientras estaba siendo aprovechado activamente por atacantes, se convierte en un grave 0day. Adobe ha reconocido finalmente la vulnerabilidad como una nueva amenaza, para la que no existe parche disponible. Esperan publicar uno el día 11 de marzo.

Poco después de que ShadowServer detectase ataques a través de archivos PDF, Adobe ha reconocido que se trata de una nueva vulnerabilidad crítica. Un desbordamiento de memoria intermedia que permite ejecución de código. Symantec ya advirtió el día 12 de febrero de un potencial nuevo ataque llevado a cabo a través de archivos PDF abiertos con Acrobat. Todavía no se sabe si se trata de la misma vulnerabilidad. Si fuese así, el archivo PDF parece que es detectado desde el 11 de febrero por varios motores antivirus. Actualmente, según nuestros registros en VirusTotal.com, se ha recibido ocho veces la misma muestra y es detectada (por firmas) por 13 motores de 39.

El fallo afecta a todas las plataformas y a todas las ramas mantenidas por el fabricante, tanto de Adobe Acrobat como de Adobe Reader. Actualmente la 9, 8 y 7. Adobe anuncia que solucionará el fallo con parches que aparecerán sobre el 11 de marzo para la rama 9 y "más tarde" para el resto de versiones. El boletín se publicará en http://www.adobe.com/support/security.

El fabricante no proporciona ninguna información sobre cómo mitigar el problema. Al parecer es posible que la desactivación del JavaScript permita estar protegido, pero no puede garantizarse. Mientras tanto, se recomienda no abrir documentos PDF con Adobe no solicitados o usar lectores alternativos como por ejemplo Foxit Reader (gratuito para Windows) o Xpdf para el resto de plataformas.


Sergio de los Santos
ssantos@hispasec.com


Más información:

Buffer overflow issue in versions 9.0 and earlier of Adobe Reader and Acroba
http://www.adobe.com/support/security/advisories/apsa09-01.html

Trojan.Pidief.E
http://www.symantec.com/business/security_response/writeup.jsp?docid=2009-021212-5523-99&tabid=1

No hay comentarios:

Publicar un comentario en la entrada