miércoles, 13 de mayo de 2009

Actualizaciones de seguridad para Adobe Reader y Acrobat

Adobe ha publicado actualizaciones para corregir dos vulnerabilidades en Adobe Reader y Acrobat en diferentes plataformas, que podrían permitir a un atacante tomar el control de los sistemas afectados.

El primero de los problemas, que afecta a Adobe Reader 9.1 y Acrobat 9.1 (y versiones anteriores), reside en el método getAnnots Doc en la API de JavaScript. El fallo podría permitir a un atacante remoto la ejecución de código arbitrario mediante un pdf que contenga una anotación y una entrada OpenAction con código JavaScript que llame a dicho método con argumentos enteros modificados

También se ha anunciando una segunda vulnerabilidad que afecta únicamente a Adobe Reader para UNIX. El problema, que reside en el método spell customDictionaryOpen en la API de JavaScript, podría permitir a un atacante remoto lograr la ejecución remota de código arbitrario mediante un archivo PDF con una llamada al método con una cadena de gran tamaño como segundo argumento.

Adobe recomienda a los usuarios de Adobe Reader 9.1 y Acrobat 9.1 (y versiones anteriores) actualizar a Adobe Reader 9.1.1 y Acrobat 9.1.1. Para los usuarios de Adobe Reader que no puedan actualizar a Adobe Reader 9.1.1, Adobe ha publicado las versiones actualizadas Adobe Reader 8.1.5 y Adobe Reader 7.1.2.

Las actualizaciones están disponibles desde:
Para Adobe Reader en Windows: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Windows.

Para Adobe Reader en Macintosh: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Macintosh.

Para Adobe Reader en UNIX: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Unix.

Para Acrobat Standard, Pro y Pro Extended en Windows:
http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Window.

Para Acrobat 3D en Windows:
http://www.adobe.com/support/downloads/product.jsp?product=112&platform=Windows.

Para Acrobat Pro en Macintosh:
http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Macintosh.


Antonio Ropero
antonior@hispasec.com


Más información:

Security Updates available for Adobe Reader and Acrobat
http://www.adobe.com/support/security/bulletins/apsb09-06.html

No hay comentarios:

Publicar un comentario en la entrada