viernes, 23 de octubre de 2009

Denegación de servicio a través de paquetes IPv6 en Snort

Se ha descubierto un fallo de seguridad en Snort 2.8.5 que podría permitir a un atacante remoto efectuar ataques de denegación de servicio.

Snort es uno de los IDS (Sistema de Detección de Intrusiones) más extendidos. Distribuido de forma gratuita como Open Source, Snort puede detectar muchos de los patrones de ataque conocidos basándose en el
análisis de los paquetes de red según unas bases de datos de firmas, además de reglas genéricas. Habitualmente la función de estos detectores es la de alertar sobre actividades sospechosas a través de cualquier mecanismo, aunque en ocasiones puede usarse para lanzar medidas destinadas a mitigar de forma automática el posible problema descubierto por el sensor.

El error anunciado se presenta cuando snort se ha compilado con la opción --enable-ipv6 y se ejecuta en modo detallado (-v). Un atacante remoto podría provocar una denegación de servicio a través de paquetes
IPv6 especialmente manipulados.

Se ha publicado la versión 2.8.5.1 que corrige este problema y se encuentra disponible desde :
http://www.snort.org/downloads


Laboratorio Hispasec
laboratorio@hispasec.com


Más información:

Snort 2.8.5 IPv6 Remote Denial of service
http://g-laurent.blogspot.com/

No hay comentarios:

Publicar un comentario en la entrada