jueves, 29 de octubre de 2009

Tres vulnerabilidades en el navegador Opera

Se han identificado y corregido tres vulnerabilidades que afectan al navegador Opera (versiones anteriores a 10.01). Un atacante podría hacer uso de ellas para evitar restricciones de seguridad, falsificar o conseguir información o llegar a comprometer los sistemas afectados.

La primera de las vulnerabilidades se trata de un error de degradación de memoria al procesar nombres de dominio específicamente construidos, esto podría provocar la ejecución de código arbitrario a través de una
página creada con propósitos maliciosos.

El segundo de los problemas está provocado por errores de validación de entrada en la página de suscripción a feed al procesar determinados scripts, esto podría dar lugar a la suscripción automática a feeds, o leer otros feeds.

Por último, un error provocado por el tratamiento de fuentes Web al generar partes del interfaz de usuario, esto podría permitir que un sitio web malicioso mostrara un dominio falso en el campo de dirección. Un atacante podría usar esta vulnerabilidad para falsificar sitios web, crear ataques de phishing, etc.

Se recomienda actualizar a Opera versión 10.01 disponible desde:
http://www.opera.com/browser/


Antonio Ropero
antonior@hispasec.com


Más información:

Opera 10.01 for Windows Changelog
http://www.opera.com/docs/changelogs/windows/1001/

Advisory: Certain domain names can allow execution of arbitrary code
http://www.opera.com/support/search/view/938/

Advisory: Opera may allow scripts to access feeds
http://www.opera.com/support/search/view/939/

Advisory: Web fonts can be used to spoof the page address
http://www.opera.com/support/search/view/940/

No hay comentarios:

Publicar un comentario en la entrada