jueves, 25 de febrero de 2010

Vulnerabilidad de ejecución de código en Google Picasa

Se ha descubierto una vulnerabilidad en Google Picasa por la que un usuario remoto podría lograr la ejecución de código en el sistema de los usuarios.

Picasa es un software de tratamiento y gestión de fotografías de Google, con el que se puede organizar, editar e imprimir las fotos del ordenador.

El problema consiste en que un usuario remoto podría crear una imagen en formato jpeg de tal forma, que cuando fuera cargada por el usuario atacado y este realice cualquier acción se provoque un desbordamiento de entero en "PicasaPhotoViewer.exe" y la ejecución de código en el sistema del usuario. El código se ejecutará con los privilegios del usuario.

Aunque no ha realizado ninguna comunicación al respecto, Google ha publicado una versión que corrige el problema (3.6 build 105.41).


Antonio Ropero
antonior@hispasec.com


Más información:

Google Picasa Integer Overflow in Processing JPEG Images Lets Remote Users Execute Arbitrary Code
http://securitytracker.com/alerts/2010/Feb/1023652.html

No hay comentarios:

Publicar un comentario en la entrada