sábado, 6 de marzo de 2010

Vulnerabilidad en kit de desarrollo Autonomy KeyView afecta a diversos fabricantes

Se ha confirmado la existencia de de una vulnerabilidad en el kit de desarrollo Autonomy KeyView que afecta a diversos fabricantes como Symantec o IBM.

Autonomy KeyView es un kit de desarrollo comercial que proporciona librerías para el tratamiento de múltiples formatos de archivos, soporta un gran número de documentos en diferentes formatos y muchos fabricantes hacen uso de esta librería para procesar documentos.

El problema reside en un desbordamiento de entero en el filtro de Autonomy KeyView que puede permitir a un atacante remoto la ejecución de código arbitrario con los privilegios de la aplicación atacada.

Se ha confirmado esta vulnerabilidad al menos en las siguientes versiones del softrware:
kvolefio.dll versión 8.5.0.8339, distribuido con IBM Lotus Notes 8.5
kvolefio.dll versión 10.5.0.0, distribuido con Symantec Mail Security para Microsoft Exchange

Symantec ha publicado una actualización para corregir el problema, disponible a través del aviso publicado en:
http://www.symantec.com/business/security_response/securityupdates/det
ail.jsp?fid=security_advisory&pvid=security_advisory&year=2010&suid=20
100304_00


Antonio Ropero
antonior@hispasec.com


Más información:

Autonomy KeyView OLE Document Integer Overflow Vulnerability
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=858

No hay comentarios:

Publicar un comentario en la entrada