lunes, 25 de julio de 2011

Nueva versión de Foxit Reader corrige dos graves vulnerabilidades

Foxit ha corregido dos vulnerabilidades Foxit Reader que podrían permitir a un atacante la ejecución de código arbitrario.

Foxit es un lector de PDF de la compañía Foxit Software, gratuito en su versión Reader y con versión de pago que permite modificar PDFs. Supone una alternativa más ligera y menos "atacada" al lector de Adobe.

La primera vulnerabilidad, reportada por Dmitriy Pletnev de Secunia, está provocada por una falta de comprobación de límites que lleva a un desbordamiento de memoria basado en heap.

La segunda vulnerabilidad, reportada por Rob Kraus de Security Consulting Services (SCS), se trata del conocido "DLL hijacking" que ha afectado a tantas aplicaciones desde hace unos meses. Igualmente permite la ejecución de código si la víctima abre un archivo PDF desde una unidad remota.

Los dos problemas han sido corregidos en la versión 5.0.2.0718. La compañía tuvo conocimiento de forma privada de estos errores el 11 y el 20 de junio respectivamente. Se recomienda actualizar con la mayor brevedad a aquellos usuarios que utilicen esta aplicación.


Sergio de los Santos
ssantos@hispasec.com
Twitter: @ssantosv

Jose Ignacio Palacios Ortega
jipalacios@hispasec.com


Más información:

Building the Most Secure PDF Reader
http://www.foxitsoftware.com/Secure_PDF_Reader/security_bulletins.php

No hay comentarios:

Publicar un comentario en la entrada