sábado, 28 de abril de 2012

Nueva versión de PHP corrige dos vulnerabilidades


Recientemente el equipo de desarrollo de PHP ha publicado las actualizaciones para las ramas 5.3 y 5.4 de PHP que solucionan dos vulnerabilidades que pueden ser aprovechadas para evadir restricciones de seguridad y llevar a cabo ataques de inyección SQL.

La primera vulnerabilidad afectaba a las versiones 5.3 y 5.4 (CVE-2012-1172) y fue descubierta por Neal Poole. Debido a una validación insuficiente, un script PHP que aceptase múltiples subidas de archivos en una misma petición podría corromper los índices del array $_FILES (que maneja información de las subidas de archivos) y provocar el acceso a directorios no autorizados por parte de un atacante remoto usando nombres de archivos especialmente modificados.

La segunda vulnerabilidad sólo afectaba a la versión 5.3 (CVE-2012-0831). Durante la importación de variables de entorno no se realiza correctamente un cambio temporal de la directiva 'magic_quotes_gpc'. Esto hace fácil a un atacante remoto llevar a cabo inyecciones de código SQL en el sistema vulnerable a través de una petición especialmente diseñada para ello.

PHP insta a actualizar cuanto antes a las nuevas versiones  5.3.11 y 5.4.1 desde http://www.php.net/downloads.php

Más información:

PHP 5.3.11 And PHP 5.4.1 Released!


Daniel Vaca

No hay comentarios:

Publicar un comentario en la entrada