sábado, 26 de mayo de 2012

Múltiples vulnerabilidades en Wireshark 1.x


Wireshark ha publicado tres boletines de seguridad informando de múltiples vulnerabilidades que afectan a las ramas 1.4.x y 1.6.x.

Wireshark es una aplicación de auditoría orientada al análisis de tráfico en redes. Su popularidad es muy elevada, puesto que soporta una gran cantidad de protocolos y es de fácil manejo. Además Wireshark es software libre (sujeto a licencia GPL) y se ejecuta sobre la mayoría de sistemas operativos Unix y compatibles, así como en Microsoft Windows.

Las tres vulnerabilidades publicadas tienen como impacto la denegación de servicio y como vector el uso de un paquete de trazas especialmente manipulado. A continuación una breve descripción por cada una de ellas:

  • wnpa-sec-2012-08: Varios disectores ('ANSI MAP', 'ASF', 'BACapp', 'Bluetooth' 'HCI', 'IEEE 802.11', 'IEEE 802.3', 'LTP' y 'R3') podrían provocar que la aplicación entre en un bucle infinito o lo suficientemente largo como para afectar a la disponibilidad de la aplicación.
     
  • wnpa-sec-2012-09: La aplicación podría cerrarse de forma inesperada debido a un error en la asignación de memoria en el disector "DIAMETER".
      
  •  wnpa-sec-2012-10: Debido a un error en el manejo de memoria en los procesos "SPARC" y "Itanium" la aplicación podría dejar de funcionar.

Estas vulnerabilidades se han solucionado en las versiones 1.4.13 y 1.6.8. Ambas actualizaciones pueden ser descargadas desde:

Más información:

Infinite and large loops in many dissectors

Wireshark DIAMETER memory allocation flaw

Wireshark memory alignment flaw

No hay comentarios:

Publicar un comentario en la entrada