miércoles, 16 de mayo de 2012

Vulnerabilidades en OpenOffice y LibreOffice

Se han revelado tres vulnerabilidades en OpenOffice y LibreOffice que podrían permitir llevar a cabo una denegación de servicio y la ejecución de código arbitrario.

OpenOffice y LibreOffice son suites ofimáticas de código abierto y gratuitas. Ambas cuentan con aplicaciones de hojas de cálculo (Calc), procesador de textos (Writer), bases de datos (Base), presentaciones (Impress), gráficos vectorial (Draw), y creación y edición de fórmulas matemáticas (Math).

Tielei Wang ha descubierto una vulnerabilidad identificada como CVE-2012-1149, que se debe a un error de desbordamiento de enteros en el módulo 'vclmi.dll' al asignar memoria para un objeto de imagen integrado en un documento. Un atacante remoto podría aprovechar esta vulnerabilidad para ejecutar código arbitrario si la víctima abre un documento DOC que incluya un objeto de imagen especialmente manipulado.

Otro problema es un fallo en libwpd que podría causar una sobrescritura de memoria. Este error podría ser explotado por un atacante a través de un documento WordPerfect (con formato WPD) especialmente manipulado, para lograr ejecutar código arbitrario de forma remota. Esta vulnerabilidad ha sido descubierta por Kestutis Gudinavicius, y tiene asignado el identificador CVE-2012-2149.

Sven Jacobias ha reportado otra vulnerabilidad debida a un error de control en la asignación de memoria en los filtros 'msdffimp.cxx' localizados en 'filter/source/msfilter'. Un atacante remoto podría llevar a cabo una denegación de servicio utilizando un documento PowerPoint con registros especialmente manipulados. Se le ha asignado el identificador CVE-2012-2334.

Estas vulnerabilidades afectan a OpenOffice 3.3 y 3.4 Beta en todas las plataformas y a las versiones de LibreOffice anteriores a la 3.5.3.

Para corregir estas vulnerabilidades, se han publicado OpenOffice 3.4, y LibreOffice 3.5.3. Se encuentran disponibles para su descarga desde las páginas oficiales.

Más información:

OpenOffice.org integer overflow error in vclmi.dll module when
allocating memory for an embedded image object

OpenOffice.org memory overwrite vulnerability

Vulnerabilities related to malformed Powerpoint files in
OpenOffice.org 3.3.0

CVE-2012-1149 Integer overflows in graphic object loading

CVE-2012-2334 Denial of Service with malformed .ppt files



Juan José Ruiz


No hay comentarios:

Publicar un comentario en la entrada