lunes, 18 de junio de 2012

Elevación de privilegios en los procesadores de 64 bits de Intel


Se ha hecho público un problema de elevación de privilegios que afecta a varios sistemas operativos de 64 bits y software de virtualización que corran bajo microprocesadores de Intel.

El problema ha sido descubierto por Rafal Wojtczuk, que hablará de ello en la Black Hat 2012 en julio. La vulnerabilidad está basada a su vez en un fallo similar encontrado en el kernel de Linux en 2006.

Para aprovechar esta vulnerabilidad, un atacante local previamente autenticado, debe ejecutar una aplicación específicamente diseñada para ser ejecutada por el kernel después de una excepción de "protección general" (#GP). El fallo será manejado antes del cambio de pila, por lo que el manejador de la excepción será ejecutado en el kernel en un RSP (registro de puntero de pila) elegido por el atacante.

Si es explotado con éxito, este agujero de seguridad podría aprovecharse para escalar privilegios y pasar del ring3, que supone el espacio de usuario, al ring0, que es el espacio con máximos privilegios donde se mueve el kernel. Es posible también escapar de un sistema de virtualización que esté corriendo en un sistema operativo de 64 bits.

Se encuentran afectados numerosos sistemas operativos. Red Hat, Windows y FreBSD ya han publicado parche oficial. El sistema de virtualización Xen también ha publicado una actualización.

Apple, VMware y en general los procesadores ARM o AMD, no se ven afectados por este problema.

Más información:

SYSRET 64-bit operating system privilege escalation vulnerability on Intel CPU hardware
http://www.kb.cert.org/vuls/id/649219


Daniel Vaca

2 comentarios:

  1. ¿Pero es un fallo del procesador o del sistema operativo? Porque el titular idce una cosa pero la noticia parece que dice otra....

    ResponderEliminar
  2. El fallo original está en el procesador de 64 bits. Otra condición adicional para ser vulnerable es que el sistema operativo que corra en ese procesador debe ser de 64 bits (porque también pueden usarse de 32 bits en plataformas de 64). Por otro lado, Xen (software de virtualización) también se ve afectado.

    ResponderEliminar