miércoles, 11 de julio de 2012

Grave vulnerabilidad en Plesk está siendo aprovechada por atacantes

Se ha conocido que un grave problema de seguridad en Plesk está siendo aprovechado activamente por atacantes, y que numerosas páginas webs y servicios de hosting se están viendo afectados por este problema. Aunque no se conocen muchos detalles del fallo, es posible que los detalles estén a la venta en foros underground.

Parallels Plesk es un software muy popular. Se trata de un panel de administración que simplifica la gestión de servidores web. Es muy usado en empresas de hosting para que los usuarios administren sus recursos: páginas, DNS, correos... etc.

El fallo permite obtener la contraseña maestra para el panel de control de Plesk de las versiones 10.4.4 y anteriores. No existe solución oficial. La compañía Parallels, responsable del programa, ha emitido un comunicado oficial donde reconoce estar al tanto del problema, pero no ofrece detalles técnicos de la vulnerabilidad, solo que "parece estar basada en vulnerabilidades anteriores ya parcheadas". Seguirán informando tan pronto obtengan más información al respecto.

En ciertos foros underground, un reputado usuario vende una vulnerabilidad de Plesk no solucionada por 8.000 dólares. Al mismo tiempo, se ha observado que miles de páginas (50.000 según Sucuri Malware Labs) están siendo atacadas recientemente, con el único punto en común de usar Plesk para su administración. Por tanto, puede que ambos hechos se encuentren relacionados.

Los sitios afectados comienzan a servir exploits a los visitantes que a su vez, si tienen éxito, instalan malware en los sistemas.

Se recomienda a los administradores de páginas que usen Plesk, actualicen a la última versión 11.0 (aunque por ahora no se sabe si también se ve afectada por el problema) y que analicen la seguridad de las páginas alojadas.

Más información:

Security Advisory for Parallels Plesk Panel 10.4

Plesk 0Day For Sale As Thousands of Sites Hacked

Plesk vulnerability remediation tips


Jose Ignacio Palacios

5 comentarios:

  1. Me pregunto si yahoo está siendo afectado por estos atacantes, desde el día de ayer no se puede acceder a las cuentas de correo.
    Lo he probado con diferentes navegadores: ie9, google crome, safari, mozilla firefox. Y de diferentes lugares de la ciudad de Quito, Ecuador, con diferentes computadores.
    Al final no se puede ingresar a yahoo.

    ResponderEliminar
  2. ¿Que tiene que ver yahoo, con plesk? ¿Ayer no me arrancaba el coche, quizá es porque se ve afectado por estoa atacantes?

    ResponderEliminar
  3. Buenas,

    dada la supuesta gravedad de este anuncio, comentar que Parallels considera esta vulnerabilidad como infundada y que los sistemas afectados probablemente lo estén por vulnerabilidades anteriores según se puede extraer del enlace a la web oficial y debidas a que no se aplicaron completamente todos los pasos recomendados en la solución a esa vulnerabilidad anterior. Concretamente, parece ser que no se ha realizado el cambio masivo de contraseñas o se han vuelto a restablecer las contraseñas comprometidas.


    Saludos,
    Eric Janz

    ResponderEliminar
  4. #1 No creo que tu problema tenga que ver con este de arriba, aunque por mucho que diga #2, puede ser que Yahoo funcione bajo servidores Plesk, aunque lo desconozco, pero ya te digo que dudo que este sea tu problema.

    Respecto a Eric, he hablado esta mañana con Plesk Parallel, y me han comentado que estan solucionando el problema sin tener que tocar nada "que afecte a los "usuarios"", de todas formas, no sé como se terminará reparando la cosa, lo más probable es que sí se tomen medidas como las que acabas de comentar, aunque de momento no se han hecho, al menos no en mi servidor.

    Un saludo.

    ResponderEliminar
  5. Parece ser que son miles y miles las paginas afectadas en Internet desde hace varias semanas, espero que Parallels ponga una solución definitiva a todo esto

    ResponderEliminar