sábado, 9 de agosto de 2014

Actualización del kernel para SuSE Linux Enterprise 10

SuSE ha publicado una actualización del kernel para SuSE Linux Enterprise Server 10 SP3 LTSS. Se han solucionado 17 vulnerabilidades e incluye 2 correcciones.

Los problemas corregidos están relacionados con la generación de direcciones IPv6 temporales, el subsistema HID (Human Interface Device), el uso de UDP Fragmentation Offload (UFO), múltiples desbordamientos de búfer cuando se usa CONFIG_IP_VS, múltiples subdesbordamientos de búfer en la implementación XFS, la inicialización de determinadas estructuras de datos y con el tratamiento de llamadas FDRAWCMD ioctl.

Otros problemas están relacionados con la función ipc_rcu_putref en ipc/util.c, la función aac_compat_ioctl de drivers/scsi/aacraid/linit.c, la función l2tp_ip_recvmsg en net/l2tp/l2tp_ip.c y la función pn_recvmsg en net/phonet/datagram.c .

Además se han corregido otros dos problemas no relacionados directamente con fallos de seguridad.

Los CVE asignados son: CVE-2013-0343, CVE-2013-2888, CVE-2013-2893, CVE-2013-2897, CVE-2013-4470, CVE-2013-4483, CVE-2013-4588, CVE-2013-6382, CVE-2013-6383, CVE-2013-7263, CVE-2013-7264, CVE-2013-7265, CVE-2014-1444, CVE-2014-1445, CVE-2014-1446, CVE-2014-1737 y CVE-2014-1738.

En todos los casos los problemas podrían permitir evitar restricciones de seguridad, obtener información sensible, elevar los privilegios del usuario, realizar ataques de denegación de servicio, ejecución de código arbitrario y otros impactos no especificados.

Se recomienda actualizar a la última versión del kernel, disponible a través de la herramienta automática YaST con el módulo "Online Update" o con la herramienta de línea de comando "zypper".

Más información:

Security update for Linux Kernel SUSE-SU-2014:0832-1





Antonio Ropero
Twitter: @aropero



No hay comentarios:

Publicar un comentario en la entrada