viernes, 31 de julio de 2015

Denegación de servicio en BIND 9

ISC ha liberado una nueva versión del servidor DNS BIND. Esta versión corrige un error en todas las versiones de BIND 9, que podría causar una denegación de servicio a través de consultas especialmente manipuladas.

El servidor de nombres BIND es uno de los más usados en Internet. Creado en 1988, en la universidad de Berkeley, actualmente es desarrollado por el ISC (Internet System Consortium). BIND se encuentra disponible para una amplia gama de sistemas tanto Unix como Microsoft Windows.

El problema, con CVE-2015-5477, reside en el tratamiento incorrecto de consultas TKEY, que podría permitir a un atacante provocar condiciones de denegación de servicio que provocará el cierre del servicio named con un fallo "REQUIRE.

Se ven afectadas todas las versiones de BIND 9 desde BIND 9.1.0 (incluido) hasta BIND 9.9.7-P1 y BIND 9.10.2-P2.
Se recomienda actualizar a la versión más reciente en
BIND 9.9.7-P2 y BIND 9.10.2-P3

Cabe señalar que esta es la segunda actualización de BIND en lo que llevamos de mes. A primeros de mes ISC ya había publicado otra actualización para otra vulnerabilidad de denegación de servicio.

Más información:

CVE-2015-5477: An error in handling TKEY queries can cause named to exit with a REQUIRE assertion failure

una-al-dia (11/07/2015) Denegación de servicio en BIND 9



Antonio Ropero

Twitter: @aropero

No hay comentarios:

Publicar un comentario en la entrada