sábado, 26 de diciembre de 2015

Actualización del kernel para SuSE Linux Enterprise 11

SuSE ha publicado una actualización del kernel para SuSE Linux Enterprise Server 11 SP4 (en todas sus versiones). Se han solucionado diez vulnerabilidades e incluye 57 correcciones de funcionalidades no relacionadas con seguridad.

El más grave de los problemas corregidos podría permitir a usuarios locales la elevación de privilegios por un fallo en arch/x86/entry/entry_64.S en plataformas x86_64 al procesar NMIs. Una denegación de servicio remota usando IPv6 RA con MTU falso. El resto de problemas podrían permitir causar condiciones de denegación de servicio de forma local, por bucl

Un error en arch/x86/entry/entry_64.S en plataformas x86_64 puede permitir la elevación de privilegios al tratar NMIs. En RDS no se verifica la existencia de transporte subyacente al crear una conexión lo que provoca el uso de un puntero nulo. Una denegación de servicio remota a través de valores MTU manipulados en un mensaje IPv6 Router Advertisement (RA)

Por otra parte denegaciones de servicio locales al montar sistemas de archivos ext4 en modo no-journal, en la función "slhc_init" de "drivers/net/slip/slhc.c", en el subsistema KVM, en la función "key_gc_unused_keys" de "security/keys/gc.c" a través de comandos keyctl manipulados y en la función "__rds_conn_create" de "net/rds/connection.c".

Los CVE asignados son: CVE-2015-7509, CVE-2015-7799, CVE-2015-8104, CVE-2015-5307, CVE-2015-7990, CVE-2015-5157, CVE-2015-7872, CVE-2015-0272 y CVE-2015-6937.

Además se han corregido otros 57 problemas no relacionados directamente con fallos de seguridad.

Se recomienda actualizar a la última versión del kernel, disponible a través de la herramienta automática YaST con el módulo "Online Update" o con la herramienta de línea de comando "zypper".

Más información:

SUSE Security Update: Security update for Linux Kernel
SUSE-SU-2015:2339-1




Antonio Ropero

Twitter: @aropero

No hay comentarios:

Publicar un comentario en la entrada