jueves, 7 de enero de 2016

Diversas vulnerabilidades en PHP

El equipo de desarrollo de PHP ha publicado actualizaciones para las ramas 7.0, 5.6 y 5.5 de PHP para solucionar múltiples vulnerabilidades que pueden ser aprovechadas para provocar denegaciones de servicio e incluso comprometer los sistemas afectados. 

Las actualizaciones incluyen la corrección de múltiples problemas y vulnerabilidades. Aunque no hay CVEs asignados se corrigen vulnerabilidades de fuga de memoria en "header_register_callback", de fuga de memoria y desbordamiento de búfer en fpm_log.c, una lectura fuera de límites en gdImageRotateInterpolated, un desbordamiento de búfer en funciones escapeshell, vulnerabilidades de uso después de liberar memoria en WDDX y por último una confusión de tipos en PHP_to_XMLRPC_worker.

Se recomienda actualizar a las nuevas versiones 7.0.2, 5.6.17 y 5.5.31 desde
http://www.php.net/downloads.php

Más información:

PHP 7 ChangeLog

Version 5.5.31

Version 5.6.17


Antonio Ropero
Twitter: @aropero

No hay comentarios:

Publicar un comentario en la entrada