Microsoft publica un nuevo parche acumulativo para las versiones 5.01,
5.5 y 6.0 de Internet Explorer. Además de los parches anteriores, se
corrigen dos vulnerabilidades que pueden permitir a un atacante ejecutar
código malévolo en la máquina del usuario.

El nuevo parche publicado por Microsoft es del tipo acumulativo; es
decir, se incluyen todas las actualizaciones para los diversos problemas
de seguridad en Internet Explorer conocidos hasta la fecha. Por tanto,
una vez aplicado podemos tener la certeza de que el navegador dispone de
todas las actualizaciones publicadas hasta el día de hoy.

Adicionalmente, el nuevo parche soluciona dos nuevos problemas de
seguridad, calificados como críticos ya que pueden ser utilizados por un
atacante para forzar la ejecución de código en la máquina del usuario de
Internet Explorer.

La primera de las nuevas vulnerabilidades se encuentra en los mecanismos
de seguridad que utiliza Internet Explorer para impedir la comunicación
entre dos ventanas que estén accediendo a dominios diferentes. Debido a
que los mecanismos existentes no son suficientes, existe la posibilidad
de que un atacante consiga ejecutar código arbitrario en la máquina del
usuario vulnerable (enviando un programa o forzando la ejecución de un
ejecutable presente en la máquina del usuario). Para aprovecharse de
esta vulnerabilidad el atacante debe convencer al usuario que visite una
página web especialmente preparada.

La segunda de las nuevas vulnerabilidades se encuentra en la forma en
que Internet Explorer utiliza la función showHelp() para visualizar una
página HTML de ayuda. La vulnerabilidad permite a un atacante utilizar
esta función para abrir una página sin que se realicen las
comprobaciones de seguridad suficientes.

Como en el caso anterior, esta segunda vulnerabilidad también puede ser
aprovechada para ejecutar código o bien acceder a la información
almacenada en la máquina del usuario.

Una vez aplicado este parche acumulativo, showHelp() dejará de
funcionar. Microsoft ha publicado también una nueva versión del motor de
ayuda HTML que utiliza un nuevo método para acceder a las páginas HTML
de ayuda.

El parche publicado por Microsoft puede instalarse en las máquinas que
ejecuten Windows 2000 Service Pack 3 con Internet Explorer 5.01 y
Service Pack 3; en Internet Explorer 5.5 con Service Pack y en todas las
versiones de Internet Explorer 6.0. Está disponible en la siguiente
dirección:

http://www.microsoft.com/windows/ie/downloads/critical/810847/default.asp

La nueva versión del motor de ayuda HTML (811630), necesaria para
visualizar las páginas HTML de ayuda una vez instalado el parche
acumulativo, en el momento de escribir este boletín sólo puede
instalarse a través del servicio Windows Update.

Xavier Caballé
xavi@hispasec.com

Más información:

Boletín de seguridad de Microsoft (MS03-004)
Cumulative Patch for Internet Exploter (810847)
http://www.microsoft.com/technet/security/bulletin/MS03-004.asp

What You Should Know About Microsoft Security Bulletin MS03-004
Security Update for Microsoft Internet Explorer
http://www.microsoft.com/security/security_bulletins/ms03-004.asp

Improper Cross Domain Security Validation with dialog box
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-1326

Improper Cross Domain Security Validation with ShowHelp functionality
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-1328

Dangerous security hole, IE needs patching again
http://www.theinquirer.net/?article=7640

IE security disabled via showHelp(«file:») cross site/zone scripting
http://www.securitybugware.org/NT/5976.html

If it’s Thursday it must be IE patching day
http://www.theregister.co.uk/content/55/29208.html

showHelp(«file:») disables security in IE – Sandblad advisory #11
http://online.securityfocus.com/archive/1/310684

Compártelo: